Lamborghini Talk banner
1 - 8 of 8 Posts

·
Premium Member
Joined
·
52 Posts
Discussion Starter · #1 ·
Good Afternoon All!

I have had this Tank System Malfunction ("TSM") problem for quite a while, and it has appeared only after the EVAP Recall was done to the Car.

Symptoms:
1. When the Tank is slightly less than Half Full, the Fuel Reading goes to 0 with a TSM output on the Cluster
2. The Fuel Reading after 3/4 Tank becomes incorrect as when the Reading shows 1/2 tank it is only in reality I believe 15% petrol left
3. I was parked one day on an incline with the car turned on, then suddenly there is a TSM output, once I started driving the Fuel Reading came back to life

Solutions I have tried:
1. I have replaced both fuel pumps
2. Done the necessary adaptation

Any idea what is going on, as when the tank is full the reading is fine but just after that things start to go haywire.

Appreciate the Help and Input in Advance.
 

·
Registered
Joined
·
11 Posts
Hello, I have similar issues and my tech says its probably the fuel sender unit. Evap recall was done 2 yrs ago no issue after. My problem started a week ago after a full tank fill up. Seems intermittent and I get TSM message on cluster when fuel suddenly reads
empty on gauge, after driving for a while it goes back to half tank. Appreciate if u have a fix. Hope that engine doesnt need to come out to reach the tank/ sender unit, pumps etc.
 

·
Premium Member
Joined
·
52 Posts
Discussion Starter · #3 ·
So I replaced the fuel pumps and the wiring and the problem still did not go away. What they did was they changed the "adaptor" and the "connector points" for the fuel pumps which made the issue completely disappear.

Hope this helps.
 

·
Premium Member
Joined
·
1,000 Posts
I've no idea what the adaptor & connector points are in the fuel pumps. I supposed that is the wiring that attaches to the fuel pump?

Glad that you had it fixed.
 

·
Registered
Joined
·
11 Posts
It is the point at which the fuel pumps draw power from the electrical system. Kind of like a socket.
thanks for the input glad that you solved the problem. Does the fuel tanks need to come out thus the whole engine or do you reach the fuel assembly without?
 

·
Premium Member
Joined
·
52 Posts
Discussion Starter · #7 ·
The work does not require an engine out. Fuel tanks were only moved slightly. From what I understood, because all connectors and the adaptor was not working, hence all information was not being sent properly.
 
1 - 8 of 8 Posts
Top