Lamborghini Talk banner
1 - 9 of 9 Posts

·
Registered
Joined
·
115 Posts
Discussion Starter · #1 ·
When preparing my 04 G for a season of driving I had 2 new errors that I have never seen before with many years of owning my G:
"Right Side Turn Signal"
"Left Side Turn Signal"
1.jpg 2.jpg


As usual I did some Google and forum searches and quickly realized that this error is more common than I would have thought, but more importantly I realized that there was no legitimate "solution" other than to take it to the dealer and have them clear the codes(which still doesn't work for many owners). There was also no real reason why these error codes appeared for most owners which was another problem(how to find a solution to a problem without knowing its origin). I first tried to clear it myself using a typical OBDII scanner, even though I knew it probably would not work as others have mentioned. Of course it did not work so I scheduled a Lamborghini dealer visit and about 2 hours into the appointment the Lamborghini tech said that he can't clear the error codes(and just to be clear I am referring to an actual Lamborghini dealership and their authorized Lamborghini technician who is the sole Lamborghini tech at the dealership which is in metro Detroit, so my point is that it is not some novice technician...) He said they occasionally have a Gallardo come in with the same error codes but that they have always been able to clear it but for some reason this time they aren't able to. After another hour of him being on the phone with various other technicians he found the solution and I simply wanted to post it for anyone who has this issue in the future. Keep in mind that this solution only applies to non-European Gallardos.

THE PROBLEM: During the winter I had some work done on the car and the battery was unplugged all winter long. However apparently the Gallardo can revert to default settings IF THE COMPUTER DOES NOT HAVE POWER OVER A 3+ MONTH PERIOD. This was confusing to me because I would have assumed that no power for a few weeks would be equivalent to no power for months but that is not the case. What happened is that the computer setting was reset to be a "EUROPEAN" model instead of the US model it was, and therefore the computer was looking for the blinking side markers which are a legal requirement across Europe but NOT on non-European models. Since the computer did not see the proper blinking side markers it was then throwing these error signals.

THE SOLUTION: Clearing the codes with the dealership's LARA computer did not work as mentioned, but once he figured out what happened he had to change the setting so that the car saw itself as a non-European model. There was one setting he had to change and I don't know exactly what this means but a Lamborghini tech should know and I am providing it in hopes of saving your tech time and money. This is what he did to change that setting using the LARA computer:
Channel 19
Change the code to be: 01100
Using the "Kombi Adaption"



So hopefully this can help out a fellow rider and if you have any questions feel free to ask!
 

·
Registered
Joined
·
944 Posts
Thank you for the explanation.
 

·
Registered
Joined
·
740 Posts
THAT is outstanding information. Great job of detective work by the Lambo tech and thanks for posting on the forum.
 

·
Registered
Joined
·
44 Posts
I know this is a little old, but worth a bump.

My car is a Canadian car that requires daytime running lights full time. My daytime running lights do not work. I have the left and right turn signal errors all the time.

I'm wondering if an even more reliable way to diagnose this is also when your DRLs stop working, is another way to establish your lighting module has reverted to EU spec and this fix needs to be implemented.

Thoughts?
 

·
Registered
Joined
·
77 Posts
Thank you

Hello, I just wanted to post a big thank you for putting the information in your post on how the dealer fixed your left turn signal right turn signal error.

I took my car to the dealer in Vaughn, Ontario the other day and provided them the information and I was out of there in less than 5 minutes. (They still charged me $190.00)

Anyway, the error is gone now, so thank you!
 

·
Registered
Joined
·
44 Posts
Hello, I just wanted to post a big thank you for putting the information in your post on how the dealer fixed your left turn signal right turn signal error.

I took my car to the dealer in Vaughn, Ontario the other day and provided them the information and I was out of there in less than 5 minutes. (They still charged me $190.00)

Anyway, the error is gone now, so thank you!
From my previous post, did your DRLs stop working too? I guess I may pay that much to fix it, not that bad really.
 

·
Registered
Joined
·
44 Posts
No, my DRL's still worked. Every light on my car worked, except the computer thought something was burned out.
Crap, that may bust my theory. My DRLs don't work, and it thinks both turn signals are burnt out. Not LED and they work fine.
 
1 - 9 of 9 Posts
Top