Lamborghini Talk banner

1 - 8 of 8 Posts

Registered
Joined
21 Posts
Discussion Starter #1
Hi guys I am stuck and need some guidance, with already great help from Ag02M5 and Fredapied, these guys made my first ownership issues less painful then trying to deal with it on my own. I have pulled on them too much and they need a break from my 1000 questions 馃榿 I need to expand to the masses and hope someone had a similar issue.

So I removed aftermarket radio and installed oem Headunit, everything worked except camera.
Tested camera module, found constant 6v at trigger but buttons had no effect and then tested video on external tv, image appeared.

On the Headunit, I attached the RFSL wire, and turned key on, camera image appears, but won't come off, it's stuck on reverse camera view and I cannot operate other functions of radio.
I disconnect the rfsl wire and radio goes back to operating without reverse buttons (r button and reverse view button) not turning on camera.

I removed the switch on the console button, but camera still on, Fred thinks my R button is pressed in more then normal. Not sure how to remove that lower dash panel to investigate if maybe the button is pressed just enough to keep trigger wire for camera on but not enough to switch gear to reverse.

If there is no obvious cause, I think I might turn the console camera button into a direct switch to rfsl wire, not sure if I need a relay to do this but I wouldn't mind pressing that button to reverse view at any point.

Any tips on how to wire that console button to the rfsl wire, sorry I'm not strong in electronics but willing to try.

Thanks
Cp
 

Registered
Joined
276 Posts
IS your Head unit a "Lamborghini" ?
I mean IS it written Lamborghini on it ?
See attached pic.

Perhaps your Head unit needs a few coding steps


Envoy茅 de mon SM-A405FN en utilisant Tapatalk
 

Registered
Joined
21 Posts
Discussion Starter #3
Hi Fred, yes it's a lamborghini head unit

The more I look at the console switch, I don't think it can be a two wire switch as I plan. I will cut the rfsl wire and run its open ends to the console switch and maybe piggy back to Existing plug, without messing with the can wires.
 

Registered
Joined
276 Posts
Can't you Ask how the latest unit was installed ?
Perhaps something has been changed ?

Don't forget to speak about the rusty camera module .

Fred

Envoy茅 de mon SM-A405FN en utilisant Tapatalk
 

Registered
Joined
21 Posts
Discussion Starter #5
I installed the unit . Are you questioning my skills 馃槀馃槀
The module did have corrosion from what seems to be spilled coffee, however if video feed is being transfered that would mean the module is working no? The issue seems to be the switch from can bus to request the image. From the factory the car should not have to use the rfsl wire, I believe it's can bus driven?

I tried piggy backing that rfsl wire to the button on console, no luck. After reading your Post on switch install, it's evident the buttons are no as simple as push on and off. I used open pin locations and flipped the plug around so
it could align with any one of the 3 buttons on console, nothing happened. So I guess I need a mini push button switch, without screwing up my front lift button, I will try to modify the rear camera button separately.
 

Registered
Joined
276 Posts
No, i was talking about th茅 previous one , i mean th茅 aftermarket!!


Envoy茅 de mon SM-A405FN en utilisant Tapatalk
 

Registered
Joined
21 Posts
Discussion Starter #7
Oh Sry, well there were a few previous owners, I got in contact with last two (dealers), but difficult to find info on private owners.
I'm down to 3 options to make a switch for the working rfsl wire lol.

1. Provide a relay to attach my rfsl ends, then provide power to connect those ends by using the reverse light wire.

2. Try to duplicate your drl switch 馃榿

3. Try to use fog light switch, but again those switches are fed to a circuit board, so it will be a hack job.

Oh sorry 4th option was to investigate reverse button connection, but looks like a Pia to remove that lower dash panel and risk of damaging the reverse button because its glued apparently.
 

Registered
Joined
21 Posts
Discussion Starter #8
Well went with Fredapied's awesome DIY and used the dummy Drl switch, I did mine a bit different where I went on top of the existing circuit board to save the (red) Led (it still worked when I tested it with remote power, but couldn't get the plug to pass the juice, as I removed the original 4 pin button that was on the board. I think those two were linked someone how.

Thanks again Fred 鉁
 

Attachments

1 - 8 of 8 Posts
Top