Lamborghini Talk banner

1 - 5 of 5 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hey Guys,

Quick question first Lamborghini (came from an 2010 R8 V10) the car came with a official tender from Lamborghini and when I tried plugging it in, it keeps telling me to start the engine to run tests etc on the tender. I thought it was just plug and play type charger but not sure what the issue is, does anyone have any advice, it's a 2013? Thanks!
 

·
Registered
Joined
·
11 Posts
Discussion Starter #2
Nevermind, got it working. If anyone else ever searches the same question...make sure to plug into wall outlet first then the car.

On a side note, does it eventually turn off or say charge 100% or does it keep charging?
 

·
Registered
Joined
·
66 Posts
Nevermind, got it working. If anyone else ever searches the same question...make sure to plug into wall outlet first then the car.

On a side note, does it eventually turn off or say charge 100% or does it keep charging?
Came from the same thing as you (had a 2017 V10 Plus).

Plug it in, don't worry about it. it'll switch between CHARGE/MAINTENANCE, etc.

Left it plugged in for 3 weeks while I was traveling, Came back car started up perfectly.
 

·
Premium Member
2018 Huracan Spyder 580-2
Joined
·
12,912 Posts
Mine gets plugged in even if it’s just a few days, it preserves the life of the battery.
 

·
Registered
Joined
·
598 Posts
Same as Russk, mine is always plugged in.
Unless the car is driven daily the Batt will suffer from infrequent drives, but the tender keeps the battery from deterioration.
 
1 - 5 of 5 Posts
Top