Lamborghini Talk banner
1 - 20 of 22 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter · #1 ·
Ok
new plugs and coils installed
Car ran better but still showed low circuit on cylinder 10
After plugs and coils no idle surge but still showing misfire cyl 10
Come to find out I had a bad injector and was showing 0 ohms
Replaced injector and not getting codes now but getting a idle surge when the Rpms drop after it warms up
See video
It’s like there’s a vacuum leak
I sprayed carb cleaner while running on all injectors and vacuum lines I took off. All seem to not be leaking

any ideas what may be problem?
Maybe I just need to run the car on the road to relearn?
Snow here in Michigan so that can’t happen
Have no idea how long injector has been bad as I just bought car but it’s all fixed now.


 

·
Registered
Joined
·
125 Posts
Ok
new plugs and coils installed
Car ran better but still showed low circuit on cylinder 10
After plugs and coils no idle surge but still showing misfire cyl 10
Come to find out I had a bad injector and was showing 0 ohms
Replaced injector and not getting codes now but getting a idle surge when the Rpms drop after it warms up
See video
It’s like there’s a vacuum leak
I sprayed carb cleaner while running on all injectors and vacuum lines I took off. All seem to not be leaking

any ideas what may be problem?
Maybe I just need to run the car on the road to relearn?
Snow here in Michigan so that can’t happen
Have no idea how long injector has been bad as I just bought car but it’s all fixed now.


Hi
Mine seems to be doing the same when my fans are on at the front. Which is quite often esp at traffic lights. I to have done coils plugs fuel filters etc. Are your fans runing in the video?

Sent from my SM-G930F using Tapatalk
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #6 ·
Fans not running. Put about 30 miles on the car thinking it needed to relearn. Wasn’t the case. Still surging
Hmm
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #7 ·
Put another 30 on the car tonight
Still surging
Not sure where to start troubleshooting
Only codes I’m getting are for exhaust pressure sensor which in he aftermarket exhaust
 

·
Registered
Joined
·
125 Posts
I'm running stock cats and back box. Do u still have cats?

I did clean my tbs 2 yrs ago they had a black Scum about them but didnt make much difference weird. Might try them again.

Mine seems to be worse when Ac/Heater is on. If I turn them off it settles soon after.

Got a smoke test done 6 months ago no leaks.

An independent Lambo tech suggested removing cats. Said it should help. I have flaps permanently open I see you have a sport exhaust. Exhaust flow and compression had crossed my mind. ie lack of on idle.

One thing I've never done is check the battery gauge on idle when surging. I replaced my battery about a yr ago.

Can u access live engine data on your car?

Sent from my SM-G930F using Tapatalk
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #9 ·
I actually have decats in order.
I do have a code reader but I only
Show the exhaust pressure codes which relates to my aftermarket exhaust
It’s almost like an idle control valve or something
 

·
Registered
Joined
·
125 Posts
Try this


Sent from my SM-G930F using Tapatalk
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #17 ·
That’s a good idea
But it was totally shot
Over fueling the cylinder I believe
I’m going to try cleaning the throttle bodies
 

·
Registered
Joined
·
232 Posts
The TB's are a known cause of the "hunting" in pre-LP cars. But also check that the Lambda sensors on the exhaust are working OK. Faulty Lambdas cn also idle "hunting".
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #19 ·
So are your talking about the pressure sensors attached to the cats?
The stainless tubes?
I’ve cleaned them before
Is there a sensor that goes bad?
 

·
Registered
Joined
·
232 Posts
Lambdas are the O2 sensor fore (and sometimes aft as well) of the cats; They measure oxygen not pressure. Their purpose is to to measure the oxygen levels in the exhaust and help determine the fuelling for optimal air/fuel mix. If they fail (or leak where they screw into the exhust) the computer gets variable signals telling the injectors to add fuel then measuring rich and then stop fuel hence the hunting. Happened on an old Porsche mine when the Lambda sensor was part out. Hope that helps.
 
1 - 20 of 22 Posts
Top