Lamborghini Talk banner

1 - 6 of 6 Posts

·
Registered
Joined
·
157 Posts
Discussion Starter #1
I had a weird electrical problem happen today while installing new third brake light. I put the light on and had my wife sit in the car and press the brake pedal to see if light would work and realized none of my brake lights work. I suspected brake switch but decided to check the fuses first since my radio and lighter was not working for a while. Found the fuse for the lighter blown and replaced it, I did noticed small electrical arc when putting the fuse in, not sure if that had anything to do with it. So that fixed the radio but then I started the car and I noticed my ABS light is ON. I thought maybe from pressing the brake pedal repeatedly without the car being started maybe have caused it, took it for a drive but light stayed on and started beeping every few minutes Beeep...Beeep liek 10 times, every few minutes.
Let me know if you have any suggestions. thanks guys!
 

·
Registered
Joined
·
157 Posts
Discussion Starter #3
My OBII showed no codes present I assume I need a lambo computer for this?
 

·
Registered
Joined
·
167 Posts
Have you road tested the car? Sometimes fault lights go away after even a few meters of driving. I have one car that is very sensitive like this and will throw an ABS light almost as soon as I take the wheels off the ground. As soon as it rolls a few feet the light goes off.
 

·
Registered
Joined
·
157 Posts
Discussion Starter #6
I was hoping that too and drove it for couple miles but it’s still doing it.
 
1 - 6 of 6 Posts
Top