Lamborghini Talk banner

1 - 6 of 6 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Hey all,

This is my first post. I just got a 2008 Gallardo Spyder with 4,100 miles. The front end lift system was working prior to installation of 3 M front bra and I had it up during the bra installation. Now it won't go up; the light on the dash keeps flicking after I press it but the lift system isn't working. When I turn off the engine for awhile and turn it back on the light is off. Any ideas?

Also, the rear wing doesn't go up and the malfunction light turns on while driving.

Finally, is their a replacement for the factory power steering fluid and engine oil for topping up purposes? I am about 200 miles from a dealer ion North Carolina.

Thanks for your time!

Peter
 

·
Registered
Joined
·
4,637 Posts
power steering is actually ATF in pre-Lp cars. you should confirm the fluid type in your manual.

engine oil is 5w40 for pre-lp.

you may need to take apart the wing and the plastic covering under the bonnet. it may have a broken gear or just need some lubrication. i suppose you can spray some lube to see if that help before taking it apart. Obviously, check your fuses first.

For the front lift, it could be low on PS fluid (which is ATF as mentioned earlier). Also, is the car on flat ground?
 

·
Registered
Joined
·
679 Posts
Those 2 buttons are together in the same module, I would pull up your e-gear or shift surround and make sure it didn't come unplugged.
 
1 - 6 of 6 Posts
Top