Lamborghini Talk banner
21 - 40 of 41 Posts

·
Registered
Joined
·
547 Posts
Discussion Starter · #21 · (Edited)
i wish, its a vintage modern, with low watt celestions. it sounds great without splitting the eardrums too much. the majority of time i play through my soldano lucky 13
I know what you mean... Below is my current playing setup if I get the urge to play, it will more likely change/shrink tomorrow , Only get to play once every few months or so.... And yes its under a table (that's all I am allowed for now) By the way just got the GR55 and its awesome.

Apologies in advance for the clutter and a mess, but HEY Its my mess and wives are not allowed in!!!!!! ;) Hood Automotive tire Tread Electronic instrument Musical instrument accessory
 

·
Registered
Joined
·
547 Posts
Discussion Starter · #22 ·
Gents,

I have replaced the O2 sensor on Bank 1 sensor 1 (Passenger side) and all the Bank 1 side errors are now gone but Bank 2 (driver side) errors still persist
I then replaced Bank2 sensor1, but Bank 2 errors did not go away replaced Bank2 sensor2 but unfortunately the errors still persist.
Next step to check for leaks, spark plugs, spark plug cables, injectors and the list goes on. I might pull the injectors out and send them to get rebuild/clean (as Geno did)
But before I do all the above any other suggestions anyone might have for me to check?

Below are the Errors I am getting on the driver side Bank 2 side after replacing 1 o2 sensor on the Passenger side (Bank 1) and both o2 sensor on the driver side (Bank 2)

1. P0174---- System too Lean Bank 2
2. P0175---- System Too Rich Bank 2
3. P0151---- O2 Sensor Circuit Low Voltage Bank 2 Sensor 1
4. P0152---- O2 Sensor Circuit High Volts Bank 2 Sensor 1
5. P0153---- O2 Sensor CKT slow response Bank 2 Sensor 1
6. P0154---- O2 Sensor CKT no Activity Bank 2 Sensor 1
7. P0106---- MAP/BARO CKT Range/PERF
8. P1502---- Manf Cntr 1 Veh Spd.Idle Speeg Control Auxiliary Inputs

The related OBD code for Bank 1 have been removed after replacing Bank 1 O2 sensor but did not go away after replacing both O2 sensor on the driver side Bank 2 side.

Any suggestion is greatly appreciated
 

·
Premium Member
97.0 VT Roadster / 08 Gallardo Spyder
Joined
·
1,486 Posts
Good suggestion, also your numbers 123 and 4 above are conflicting error messages with each other. They can’t both be high and low at the same time which makes me wonder if you’ve got a loose wire or a bad connection somehow. Also, did you mention that you have already disconnected the two ECUs, checked for any corrosion, and switched left and right? If not you will want to do that to isolate it to an engine issue rather than an ECU issue.
 

·
Premium Member
97.0 VT Roadster / 08 Gallardo Spyder
Joined
·
1,486 Posts
CCIE, congrats on the new ride!

yes, any tips on engine bay cleaning would be nice. There is also a cleaning section in the forum here that I have yet to check.
 

·
Registered
Joined
·
1,669 Posts
What would be the best way to clean the engine bay. View attachment 303243
Choose soap that is not corrosive, regular engine cleaner will burn out yellow zink. I use Pineline, "pine oil soap" safe and effective even for thickest grease from driveshaft. Also invorment safe and does not smell bad.

I use long dishwasher brush, spray bottle for soap and for water I use 5l pump spray bottle.

Main thing is NOT to get any water middle of engine, there is pool there in every car, with lost tools, washers and nuts from previous repair and even from factory.

My Diablo thread, fixing and service | Page 22 | Lamborghini Talk (lamborghini-talk.com)
 

·
Premium Member
97.0 VT Roadster / 08 Gallardo Spyder
Joined
·
1,486 Posts
Wouldn’t dry ice crack the already brittle electric connectors and wires?

Mikael, your comment reminds me to use my boroscrope to view the internal V of both my cars. Combined with my long articulating grabber I might find all kinds of goodies!
 

·
Registered
Joined
·
547 Posts
Discussion Starter · #36 ·
Gents,

I have replaced the O2 sensor on Bank 1 sensor 1 (Passenger side) and all the Bank 1 side errors are now gone but Bank 2 (driver side) errors still persist
I then replaced Bank2 sensor1, but Bank 2 errors did not go away replaced Bank2 sensor2 but unfortunately the errors still persist.
Next step to check for leaks, spark plugs, spark plug cables, injectors and the list goes on. I might pull the injectors out and send them to get rebuild/clean (as Geno did)
But before I do all the above any other suggestions anyone might have for me to check?

Below are the Errors I am getting on the driver side Bank 2 side after replacing 1 o2 sensor on the Passenger side (Bank 1) and both o2 sensor on the driver side (Bank 2)

1. P0174---- System too Lean Bank 2
2. P0175---- System Too Rich Bank 2
3. P0151---- O2 Sensor Circuit Low Voltage Bank 2 Sensor 1
4. P0152---- O2 Sensor Circuit High Volts Bank 2 Sensor 1
5. P0153---- O2 Sensor CKT slow response Bank 2 Sensor 1
6. P0154---- O2 Sensor CKT no Activity Bank 2 Sensor 1
7. P0106---- MAP/BARO CKT Range/PERF
8. P1502---- Manf Cntr 1 Veh Spd.Idle Speeg Control Auxiliary Inputs

The related OBD code for Bank 1 have been removed after replacing Bank 1 O2 sensor but did not go away after replacing both O2 sensor on the driver side Bank 2 side.

Any suggestion is greatly appreciated

So I have been able to trace the Bank 2 side errors to O2 sensor not seeing any voltage.... I have replaced both O2 sensors on the Bank 2 side and wondering if there is any fuse that might be associated with the O2 sensors. Other issue I suspect could be the cable going beck to the ECU. I just replaced both the O2 sensor and have ordered another one just in case the replaced sensor itself is bad. I have not had a chance to flip the ECU to see if the errors flip.
Any other ideas is greatly appreciated.
 

·
Registered
Joined
·
276 Posts
CCIE,
if you have problems first step is: Take pics of all spark plugs
These are the best indicators
on a motor. It doesnt matter if you get error codes on O2 sensors, ignition problems, fuel problems...
After this you go in detail.
This way is not new and not Pauls way. It is a very old and solid way.
Paul
 

·
Registered
Joined
·
547 Posts
Discussion Starter · #38 ·
CCIE,
if you have problems first step is: Take pics of all spark plugs
These are the best indicators
on a motor. It doesnt matter if you get error codes on O2 sensors, ignition problems, fuel problems...
After this you go in detail.
This way is not new and not Pauls way. It is a very old and solid way.
Paul
If I take the time out to remove the coils and plugs I might as well replace the plugs..... THOUGHTS?
But will do so over the break. What should I be looking for?
 

·
Registered
Joined
·
547 Posts
Discussion Starter · #39 ·
Happy Thanksgiving my Diablo Brothers!!!!!
Please also take a moment in your thoughts and prayers for the Native Americans that were massacred for what we believe to be a peaceful and celebratory time of Thanksgiving!!!!
 

·
Registered
Joined
·
1,078 Posts
Happy Thanksgiving my Diablo Brothers!!!!!
Please also take a moment in your thoughts and prayers for the Native Americans that were massacred for what we believe to be a peaceful and celebratory time of Thanksgiving!!!!
Although I don’t own a Diablo yet… Happy thanksgiving to everyone!

Fyi, all races have been massacring each other since the beginning of time, tribes slaughtered other tribes, whites slaughtered whites, blacks slaughtered blacks(still going on in the south side of Chicago), Hispanics slaughtered Hispanics, Asians slaughtered Asians. We remember. We learn. Otherwise, we repeat the sins of the past.
 
21 - 40 of 41 Posts
Top