Lamborghini Talk banner
1 - 14 of 14 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Ok, I should know better, but my 2008 Gallardo sits in a pole barn all winter. Decided it would be a good idea to wash the engine.
Sprayed some P21 on the engine and hosed it off. Engine was cold and off during the rinse. Went to start it. Had hard time starting, and h”now have CAT warning light, and the cat warning symbol on dash jumping from one side to the other. How screwed am I?
Any help is GREATLY appreciated.
 

·
Premium Member
Joined
·
907 Posts
How long has it been and is it running rough? I made a mistake of washing my murci and letting water run freely into the bay. It ran extremely rough, but after 20 minutes everything good.
 

·
Registered
Joined
·
1,881 Posts
yes, do what i do for just about anything.
If something does not work, unplug, turn it off, let it sit, and then restart.
If it does not work ,repeat.
Most of the time that will do the trick.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #4 ·
I didn’t want to run it too long.
It stalled out after about 4 mins.
Didn’t want to do damage, so only ran it a few minutes at a time.
I went with the battery disconnect, let it dry out overnight repair. Crossing my fingers it will “fix” itself.
Thanks for the responses.
I
 

·
Premium Member
2021 Huracan EVO RWD Spyder Verde Themis
Joined
·
16,805 Posts
I’ve heard off this happening to others and ever since I got to great lengths to keep the engine dry when washing the car. Once it dries out it should be fine, so I’m told.
 

·
Registered
Joined
·
807 Posts
There is a connector on the passenger side underneath the frame rail that will get wet in heavy rain or if sprayed. Water gets inside and ruins the connection and gives a temp danger. Mine has done it a few times, the last time was in torrential rain and I had to walk to an Autozone and buy a wrench and get to the connector and clean it out with brake parts cleaner to continue on. I don't remember if it is accessible with the side plastic engine panels on or off since I removed mine years ago. I posted pics about this on here years ago.

No you did not ruin anything. Just need to clean the connection it might take days to dry out on its own.
 

·
Registered
Joined
·
76 Posts
@robgreg75 Not that i am happy you had that experience in the rain, but it was a pretty funny story and I'm glad to hear people have the know how / work on them enough to do something like that!
 

·
Registered
2013 LP560 TT
Joined
·
165 Posts
@robgreg75 Not that i am happy you had that experience in the rain, but it was a pretty funny story and I'm glad to hear people have the know how / work on them enough to do something like that!
Agree with above. These cars are definitely diy accessible and I like how many owners are willing to get under the hood with them. The community support is great. Being able to wrench on mine makes me love it even more.
 
1 - 14 of 14 Posts
Top