Lamborghini Talk banner
1 - 14 of 14 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I need a little help or advice.. If anyone can lead me in the right direction.. My 91 diablo Runs perfectly on the 7-12 bank but occasionally on the 1-6 bank it loads up and backfires.. Loudly.. Scaring the neighbors.. The car starts and idles high and then it warms up starts to the idle starts to normal out. but then it surges a little dropping under 1200rpm and then it starts backfiring only on 1-6 bank.. I Actually Received SIX FLASHES on the the left checkengine light "Timing and engine speed wrong sequence".. Very confusing.. Yesterday it got better after it was hot.. Any sugguestions??

Items I checked..
* computers seem to be ok
* replaced coils
* replaced cap/rotor
* re-timed car
* TDC Sensor wire replaced ( Had a problem at the same time)
* replaced fuel filters and drained and cleaned tank

Could it be a stuck open fuel injector? or bad wires/plugs? Would that cause that error code??

thanks for any suggestions
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
thanks as always for your response.. the cap and rotor are brand new and the wires on the cap are definitely in the right place on the cap.. I disconnected all of the fuel injectors on that side to see if any were stuck open or they were leaking fuel.. No backfires... I disconnected one by one each injector to see if I could find a problem.. Still loud backfires.. I ohmed out the phase sensor pickup and it ohmed ok.. It does pick up ac current. The wires seem to be putting out good spark.. It sounds so much like a timing problem but the other bank runs perfect.. Do you think I should check fuel pressure or maybe a bad fuel pump? Can too much pressure cause this problem? Or not enough gas? I still want to say its electric.. Not sure what else to check..
 

·
Registered
Joined
·
1,462 Posts
"Loud Backfires" have to be unburned (raw) fuel of sufficient quantities being ignited in the exhaust system.

Sooo, first you must have "unburned fuel" of sufficient quantities, then you must have an ignition source, which could be spark, flame or heat (of approx. 400 degrees or better). Only a few sitiuations can produce the exact right combination of circumstances for loud Explosions in engines.

Generally, this is caused by two or more displaced/crossed wires on the same bank. If the plug wires aren't crossed at the cap then I would check or double check, as the case may be, the wires as they go to the plugs. This is by far far the most common reason for issues after the recent replacement of parts.

I use a Mechanics stethescope to listen to each injector operating if I suspect an injector issue.

As the injectors are of "the timed version", it might also be neccesary to inspect and insure the correct plug is matched with the correct injector.

Then like Carlo, you might want to check any wiring plugs you may have fiddled with.

HTH's
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
will do..

BUT THE CAR STARTS UP FINE.. THEN SURGES AND THE STARTS TO BACK FIRE.. SO TO ME THAT PRETTY MUCH SAYS THAT THE WIRES R ON CORRECTLY... CAN THE CAR RUN PROPERLY WITH CROSSED WIRES? COULD FAULTY PLUGS CAUSE THAT? I HAVE SEEN IT HAPPEN WITH A LOOSE PLUG. HOW ABOUT A BAD COIL TO CAP WIRE?

SORRY FOR ALL THE QUESTIONS..?
JUST TRYING TO SOLVE THIS F^&*^*G PROBLEM.. BEFORE MY B-DAY..

THANKS AGAIN
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
I agree with the runs fine thing.. bad choice of words..

Can the engine run faster on one side than the other? causing issues?

check all wires.. the were correct in place.. also all injectors..

so I removed fuel pump fuse on 7-12 bank and the 1-6 bank did not back fire but it ran a little rough.. also shut off after a short while..

so I removed fuel pump fuse 1-6 and 7-12 runs without a problem..

But together the 1-6 back fires...

suggestions?

thanks alot

joey
 

·
Registered
Joined
·
1,462 Posts
Can the engine run faster on one side than the other? causing issues?
it sure can!! Pull the throttle rods off and check each bank with a Vacum Gauge at the plugged ports provided by the factory on each manifold. I use two gauges at the same time.

But together the 1-6 back fires...
then you definately have some type of missfire on 1-6 bank....it sounds electrial ie: Ignition in nature due to the presence of undurned fuel in the exhaust. Instead of pulling spark plug wires, try pulling the injector plugs one by one on 1-6 bank until you find the cylider/cyliders that are missing.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #9 ·
THanks.. I will check the vaccum..

I did already try the fuel injectors.. I removed one by one still backfires.. Then removed them all.. And plug them in one by one runs for a short period then backfires. Then ran the car one at a time.. Same thing.. I am running out of ideas..

I truly apprecaite the helpful insight.

Even though I dont have a TPS ERROR CODE can that cause any problems?
 

·
Premium Member
Joined
·
988 Posts
silvergts1998 said:
so what was the out come of this situation?
I just saw this thread. I have a 91 and had the same problem. It unfortunately was the computer. Switch them and see if the problem moves to the other bank.
 

·
Registered
Joined
·
733 Posts
SI LAMBO said:
I just saw this thread. I have a 91 and had the same problem. It unfortunately was the computer. Switch them and see if the problem moves to the other bank.

Where are these computers at? Also...how much was the computer?
 

·
Premium Member
Joined
·
988 Posts
silvergts1998 said:
Where are these computers at? Also...how much was the computer?
Lamborghini part is a $6,000 rip-off. I don't know anyone that will fix this part.

I'm hoping that this isn't your problem. I changed everything that was said in this thread last year: plugs, wires, cap, rota, etc. and I actually got sick when I switched the boxes and the problem moved.

Oh, almost forgot. When I switched the computers things seemed worse, so I at first didn't think this was the problem. However, when I replaced it, everything was fine.
 
1 - 14 of 14 Posts
Top