Lamborghini Talk banner

1 - 4 of 4 Posts

·
Registered
Aventador Roadster LP700-4 /// Gallardo Twin Turbo
Joined
·
5 Posts
Discussion Starter #1
Hello!

I have an issue with my Aventador so I wanted to do an engine compression test. I have removed all spark plugs and throttle bodies. But it wont crank as fast as should like when you start the car - where I made a mistake? Sounds like it hasnt got enought power. Battery is new AGM Bosch - adding other bigger one battery doesnt make any better.
Maybe theres any service procedure?
I have removed fuses for fuel pumps.

Thank you for any advice!
 

·
Registered
Joined
·
135 Posts
you don't need to remove the throttle bodies to do the compression test. I'd put those back because they serve a purpose to crank over. I've always just taken the plugs out. Let us know how it goes.
 
  • Like
Reactions: AzusilApps

·
Registered
Aventador Roadster LP700-4 /// Gallardo Twin Turbo
Joined
·
5 Posts
Discussion Starter #3
Thank you for your reply!
I put them back on and no result. Seems like it hasnt got enought power to make a full power crank. Just two-three then starter is loosing power. My compression test meter only goes to 8 bar and thats it. I wanted to do compression test because I have a problem with misfire and high temperature of catalytic converters.
 

·
Registered
Joined
·
135 Posts
how many volts are on the car when you put the key in? Also how many volts when you crank it over? Does it go to 14.2v while cranking? If it goes down toward the 10v. instead of upward than I'd say you have an issue w/ the alternator causing the issue w/ it not wanting to give you full juice to power over. I noticed you mentioned a new battery was purchased. Stupid question but have you checked the voltage on the new battery? As dumb as that sounds sometimes they're not fully charged even when new. Check that as well. You should be able to get full crank unless you have an open circuit (drain) somewhere in the system.

When did you last change the plugs and coils? (this is to your original misfire issue).
 
1 - 4 of 4 Posts
Top