Lamborghini Talk banner

1 - 12 of 12 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi, I am stranded in southern Spain with my Aventador. It seems the battery is flat and its in an underground car park with bad lighting. So i'm thinking of odering a new battery to replace it there and then incase it doesnt start off a booster pack, How much of a big job is it? I know you have to lift the front tub out etc. Would it have to be reprogrammed too as there is no lamboghini dealer for 1000km in Barcelona.

Thanks in advance for any help!
 

·
Registered
Joined
·
125 Posts
you will likely have some lingering codes. If you cant clear them they will filer out in time.Remove the tub, you will need a 13mm socket for the batery tie downs and a 10mm deep socket for the terminals. Also torx bits for the boot.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Hi!!! Thanks sooo much for the pointers there!! Do you know what would be the best battery to buy? And taking out and replacing the battery is not that hard right with a bit of mechanical experience ? Thanks sooo much again for your help, I've had so much bad luck witht he car lately it's unreal! Thanks again for your time and help1
 

·
Registered
Joined
·
125 Posts
I dont know what brands exist in your country, just buy whichever battery has the ongest warranty is my suggestion. What other problems have you had? Great when people share this stuff so when others search the forums we can find answers :)
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Hi, yes i have had problems in paint shops here in southern Spain. They had to spray the side skirts to get some stone chips out and they did it without taking them off and sparyed the air intake plastics lol. After that I orderd the air intake plastics from Lamborghini madrid and the woman who works in the parts dept husband commited suicide, so all order went on back order. After 8 Weeks of waiting i got the car back but no the battery is dead in a car park, becuase of not being used I suppose.? Any way hopefully i just swap the battery over and that's it for now! lol... Is it a hard process to change the battery ? Thanks again!
 

·
Registered
Joined
·
93 Posts
Hi there. Did you fix the problem? Could you kindly update all of us on the Forum, please? It's important we know how you got on. I hope all is well in Spain. I'm in the freezing cold UK. Lastly, how old is your battery?
 

·
Registered
Joined
·
22 Posts
Varta and other OEMs work fine. The codes can be cleared using a VAS tool with the Lambo / Audi computer. OBD II clear works as well, but run your car for a few cycles before you clear it since the harness can be affected by a 3rd party clearing tool.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #9
Hi there. Did you fix the problem? Could you kindly update all of us on the Forum, please? It's important we know how you got on. I hope all is well in Spain. I'm in the freezing cold UK. Lastly, how old is your battery?

Hi sooo sorry for the late reply!!!!!!!! All is well and the car is perfect after the battery swap. It was the original battery from 2015... All is great now, went for the 4th service at lambo too and everything was great!

Sorry again for the late reply! I did reply before, but see it wasnt posted, many apologies.... I hope the UK weather not killing you off too much? It's not too bad here in Malaga.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
Varta and other OEMs work fine. The codes can be cleared using a VAS tool with the Lambo / Audi computer. OBD II clear works as well, but run your car for a few cycles before you clear it since the harness can be affected by a 3rd party clearing tool.
Yes, all codes were cleared by my friends machine, however when I went to Lamborghini for a service they said there was some codes coming up for the suspension. All is well now though, thanks again!!1
 

·
Registered
Joined
·
34 Posts
Hi sooo sorry for the late reply!!!!!!!! All is well and the car is perfect after the battery swap. It was the original battery from 2015... All is great now, went for the 4th service at lambo too and everything was great!

Sorry again for the late reply! I did reply before, but see it wasnt posted, many apologies.... I hope the UK weather not killing you off too much? It's not too bad here in Malaga.
Do you remember if you received E-GEAR error after installing new battery? Did the dealership have to recode the e-gear?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #12
Hi! The mechanic at Lamborghini said the lingering code was suspension related, but didnt specify which part etc.. My guess it would be the E-GEAR, but i'm not too sure... There was no errors on the instrument panel. PS , sorry for late reply, the email was in spam. If you need any more help or advice give me a shout.
 
1 - 12 of 12 Posts
Top